With the Will > Portal | Forum | News | Gallery | Podcast | IRC Chat | File Island | Digital Starlight | Card Terminal | DMA | Digipedia
Results 1 to 5 of 5

Thread: Need help fixing my vpet!

  1. #1
    Ain't got no mojo...
    Join Date
    Jun 2019
    Posts
    2

    Need help fixing my vpet!

    Hi all,

    Took my vpet out from storage recently and tried to play with it (with new batteries). However, it just won’t hold its power!
    https://youtu.be/PIfOxXHqwBc


    So I took it apart and did a few things:
    1. Chip the blue-ish residue on battery connector away with a screwdriver
    2. Clean the board, and the battery connector with alcohol swab

    But it still won’t work. Same issue remains! I also don’t know where a black plastic part (see 0:10 of the YouTube video below) I supposed to go...
    https://youtu.be/6SzWG2khAJ4


    Can anyone please advise how can I salvage this mess that I’m in...? How do I fix the power issue and where should the black plastic piece go?

    Thanks!

  2. #2
    I come from the net
    Join Date
    Oct 2006
    Location
    UK
    Posts
    1,849
    Did you manage to fix the sound?

    The bit of plastic goes next to the screen:


  3. #3
    Ain't got no mojo...
    Join Date
    Jun 2019
    Posts
    2
    Quote Originally Posted by BladeSabre View Post
    Did you manage to fix the sound?

    The bit of plastic goes next to the screen:


    Thanks for the photo mate.

    i took the screen out and give the ribbon a wipe, still doesnt fix the problem. I suspect something is wrong with the power supply... but Im not sure how I can diagnose it..?

  4. #4
    That residue was probably battery leakage which has a habit of killing devices I wouldn't recommend opening a electronic device up if you don't know what you're doing and what everything is. If no one is able to help here you could try taking it to an electrician or computer store and I'm pretty sure there would be people that specialise in fixing v pets here and in other places onlie.
    You might have to maybe find replacement parts and resoldier things so good luck.
    Last edited by Donkey?; 06-23-2019 at 01:47 AM.

  5. #5
    I come from the net
    Join Date
    Oct 2006
    Location
    UK
    Posts
    1,849
    I asked about the sound because the speaker wire was detached in your picture. If the sound is working, you can tell whether the problem is just the screen, because it would still beep when you pressed buttons.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •